Password reset emails are not being sent


Our instance of Kitsu is sending invitation emails ok.

However, when we try to reset a password through the Forgot password link, the emails are not being sent.

There are no errors in the gunicorn_error.log file.

Access log shows that the reset form has been successfully called:
...."POST //auth/reset-password HTTP/1.0" 200 38....

API Status shows this:
{ "name": "Zou", "version": "0.13.2", "database-up": true, "key-value-store-up": true, "event-stream-up": true, "job-queue-up": true }

I tried to enable debug by adding:
to /etc/systemd/system/zou.service, but I can not see any debug messages in the gunicorn_error.log file.

Anything else I could try?

BTW, the password is not being reset either. I can still login with the old password.

Thank you!

OK, I fixed it. I hope this will be useful to you guys:

In the file zou/app/blueprints/auth/ on line 499 there is code:
if current_app.config["MAIL_DEBUG"]: print(message_text) else: message = Message( body=message_text, subject="CGWire password recovery", recipients=[args["email"]], ) mail.send(message)
This means that even if you have MAIL_DEBUG environment variable set to False or 0 it will still just print the message (to STDOUT by the way!) and not send it.

You have to remove the variable completely to be able to send the emails.

1 Like

Sorry we are not very active on the forum. Iā€™m glad you found a solution.